Minnesota 2 - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 14:52 UTC

Identified

The facility is undergoing maintenance on a portion of the site. The onsite team will bring the miners back online as soon as this is resolved.

We appreciate your patience and cooperation.
Posted Nov 11, 2025 - 16:28 UTC
This incident affected: Minnesota 2, United States.