Iowa 2 and Iowa 3 - Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jan 31, 2025 - 09:32 UTC

Identified

The Iowa 3 and Iowa 3 facilities are currently curtailing at Sites 1, 2, and 3. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Jan 30, 2025 - 13:39 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.