Iowa 2 and Iowa 3 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 07:13 UTC

Update

Sites 1, 1-B, and 3 are also curtailing today for 11 hours, starting from 11:00 AM to 10:00 PM Central Time.
Posted Jun 24, 2025 - 16:09 UTC

Identified

Sites 2 and 6 are curtailing today, June 24, 2025, for 13 hours, starting from 10 AM to 11 PM Central Time. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Jun 24, 2025 - 15:46 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.