Indiana 2 - Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 09:31 UTC
Investigating
We are currently investigating this issue.
Posted Apr 16, 2024 - 19:01 UTC
This incident affected: Indiana 2, United States.