Minnesota 1 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 05:01 UTC

Update

The site is still curtailing due to the persistent heat wave. We appreciate your patience and cooperation.
Posted Jun 23, 2025 - 04:08 UTC

Identified

The Minnesota is currently curtailing due to the heat coming this weekend. We will share updates as they become available. Once power is restored, our onsite team will work swiftly to bring the miners back online. We appreciate your continued patience and understanding.
Posted Jun 22, 2025 - 04:56 UTC
This incident affected: Minnesota, United States.