North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 20:33 UTC

Identified

There is currently an unexpected outage in one of the containers. Not all miners are affected. Our on-site team is actively working to resolve the issue.

Thank you for your patience and understanding.
Posted Sep 15, 2026 - 00:38 UTC
This incident affected: North Dakota, United States.