Iowa 4 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 05:17 UTC

Identified

Due to peak grid demand, the Midcontinent Independent System Operator (MISO) has issued a notice to curtail. The mining facility will curtail between the hours of 4:00 PM to 10:00 PM Central Time on June 23. Our technicians will bring miners back online as soon as possible. Thank you for your patience and understanding.
Posted Jun 23, 2025 - 15:39 UTC
This incident affected: Iowa 4, United States.