Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 30, 2025 - 17:20 UTC
Scheduled
Ohio 2 will be shutting down a portion of the site (C6) for exhaust fan troubleshooting. Our on-site team will bring the miners back online as soon as the maintenance is complete. We appreciate your cooperation.
Posted Jan 30, 2025 - 17:17 UTC
This scheduled maintenance affected: Ohio 2, United States.