Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 16:38 UTC
Scheduled
Our Ohio 2 facility will be shutting down a portion of the site (C6) for maintenance. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Mar 21, 2025 - 16:37 UTC
This scheduled maintenance affected: Ohio 2, United States.