Ohio 2 - Electrical Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Dec 01, 2023 - 01:58 UTC

Identified

The facility will undergo electrical maintenance resulting in the temporary shutdown of the miners. The onsite team will restart the miners once the maintenance is complete.
We appreciate your cooperation during this process.
Posted Nov 30, 2023 - 16:07 UTC
This incident affected: Ohio 2, United States.