Texas 5 Power Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 29, 2023 - 18:52 UTC

Identified

The facility is presently undergoing maintenance, and we anticipate this process will take approximately one hour before all workers are back up and running. Your patience is appreciated.
Posted Sep 29, 2023 - 17:01 UTC