Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 06:44 UTC

Identified

The local power authority has issued a notice to curtail. The mining facility will power down between 10:00 AM - July 28th to 12:00 AM - July 29th Central Time.

Our technicians will bring miners back online as soon as the curtailment period is complete. Thank you for your patience and understanding.
Posted Jul 28, 2025 - 05:30 UTC
This incident affected: Minnesota 1, United States.