Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 07:29 UTC

Identified

The Minnesota facility is scheduled for another curtailment today, June 3, likely due to the ongoing heat wave. The expected timeframe is 12 AM to 9 AM Central Time, though adjustments may occur. The onsite team will promptly restore the miners once power is reinstated. We appreciate your patience and understanding.
Posted Jun 03, 2025 - 05:09 UTC
This incident affected: Minnesota, United States.