Minnesota 1 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Nov 30, 2023 - 22:34 UTC

Identified

The Minnesota facility is currently curtailing. The onsite team will bring on the miners once the power has been fully restored.
We appreciate your cooperation.
Posted Nov 28, 2023 - 13:03 UTC
This incident affected: Minnesota, United States.