Texas 5 - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 16, 2025 - 06:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 15, 2025 - 13:06 UTC

Identified

Texas 5 will undergo scheduled maintenance today May 15, 2025, from 7:30 AM to 4:00 PM CST. During this time, the facility will be performing a transformer maintenance that requires powering down several Compass containers. The on-site team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted May 15, 2025 - 13:06 UTC
This incident affected: Texas 5, United States.