Minnesota 1 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 01, 2024 - 15:32 UTC
Identified
The Minnesota 1 facility is currently curtailing. Our onsite team will bring the miners back online once power is fully restored. We appreciate your cooperation.
Posted Nov 01, 2024 - 13:08 UTC
This incident affected: Minnesota, United States.