Iowa 2 and Iowa 3 - Site Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 14:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 13, 2024 - 12:03 UTC
Identified
The Iowa 2 and Iowa 3 facility will be down while the site performs maintenance. Our team will work to get the miners back online as quickly as possible. Thank you for your patience.
Posted Nov 13, 2024 - 12:01 UTC
This incident affected: Iowa 2, United States.