(81x) Indiana 2 Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 13:27 UTC
Identified
The facility is undergoing airflow maintenance until 4:30 pm EST. Any power down will be kept to a minimum.
Posted Sep 15, 2022 - 16:00 UTC
This incident affected: Indiana 2, United States.