(55x) Minnesota Power Curtailment
Incident Report for Compass Mining
Resolved
All miners at the Minnesota facility are back online. Please send us a ticket via the customer support portal if your miner is still offline.
Posted Sep 21, 2022 - 02:29 UTC
Identified
Curtailment to occur today 9/20/2022 between the hours of 12:00p.m. - 20:00p.m. CST.
Posted Sep 20, 2022 - 20:00 UTC
This incident affected: Minnesota, United States.