(55x) Minnesota Load Shedding
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 13:45 UTC
Investigating
Load shedding to occur today from 7:41AM - 8:31AM EST. The site will be back online shortly.
Posted Sep 19, 2022 - 12:27 UTC
This incident affected: Minnesota, United States.