North Dakota - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 15:51 UTC

Identified

Container #17 breaker at the mining facility has tripped, affecting 75 miners.

The onsite team will bring the miners back online as soon as this is resolved. We appreciate your patience and understanding.
Posted Sep 09, 2025 - 20:53 UTC
This incident affected: North Dakota, United States.