Manitoba 1 Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved and units are back online.
Posted Sep 27, 2022 - 20:21 UTC
Investigating
We are currently investigating the issue. Majority of the site is currently down and will provide updates here.
Posted Sep 27, 2022 - 17:58 UTC