(55x) Minnesota Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 04:20 UTC
Update
All miners are now back online
Posted Nov 28, 2022 - 04:20 UTC
Investigating
We are currently investigating this issue.
Posted Nov 28, 2022 - 00:10 UTC
This incident affected: Minnesota, United States.