(50c) Texas 1 Network Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 19:44 UTC
Identified
The site is currently down due to maintenance on the fiber at the site. Miners should be restored within 1-2 hours.
Posted Feb 06, 2023 - 18:53 UTC
This incident affected: Texas 1, United States.