Texas 2 (56X) Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 02:59 UTC
Identified
Facility is curtailing. On-site team will bring all miners online after curtailment event.
Posted Sep 25, 2022 - 18:17 UTC