Minnesota 1 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 03:46 UTC
Identified
The Minnesota 1 facility is currently curtailing. Our onsite team will bring the miners back online as soon as power is fully restored.
We appreciate your cooperation.
Posted Mar 20, 2024 - 22:51 UTC
This incident affected: Minnesota, United States.