Iowa 2 Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 21:26 UTC
Monitoring
A curtailment event is in progress at Iowa 2. Technicians are standing by to power miners back up as soon as curtailment has completed.
Posted Mar 18, 2024 - 14:12 UTC
This incident affected: Iowa 2, United States.