Nebraska 2 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 04:40 UTC

Investigating

We are currently experiencing power issues on two of our racks, impacting a total of 72 miners. Our team is actively investigating the root cause and checking whether the issue is related to the PDUs.
Posted Apr 22, 2025 - 12:28 UTC
This incident affected: Nebraska 2, United States.