Minnesota 1 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 08:44 UTC

Identified

The Minnesota facility is scheduled to curtail on April 16th from 7:00 AM to 9:00 AM Central Time. These times may change. The team will restore the miners once power returns. Thank you for your patience.
Posted Apr 16, 2025 - 06:09 UTC
This incident affected: Minnesota, United States.