Texas 5 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 11:46 UTC
Identified
The Texas 5 facility is currently curtailing. Our onsite team will bring the miners back online as soon as power is fully restored. We appreciate your cooperation.
Posted Mar 26, 2024 - 08:35 UTC
This incident affected: Texas 5, United States.