Indiana 1 and Indiana 2 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 14:19 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 18, 2025 - 14:14 UTC

Identified

The power provider at our Indiana 1 and Indiana 2 facility scheduled a curtailment today April 14th.

We will have an outage from 4:30 PM to 8:00 PM EST, lasting approximately 3 ½ to 4 hours.

We apologize for any inconvenience this may cause and appreciate your understanding as we work to comply with the demands of the power grid.

Thank you for your cooperation.
Posted Apr 14, 2025 - 22:03 UTC
This incident affected: Indiana 1, United States and Indiana 2, United States.