Nebraska 1 - Outage
Incident Report for Compass Mining
Update
We are continuing to investigate this issue.
Posted Apr 25, 2024 - 07:09 UTC
Investigating
The Nebraska 1 facility is currently experiencing a partial outage.
Posted Mar 10, 2024 - 07:21 UTC
This incident affects: Nebraska, United States.