An additional rack has been affected by a power issue, bringing the total to three impacted racks and 107 affected miners. Our team is actively investigating the situation and will share more updates shortly.
Posted Apr 18, 2025 - 06:15 UTC
Investigating
We are experiencing a power issue affecting two racks, impacting a total of 72 miners. Our team is actively investigating the root cause and working to restore normal operations as quickly as possible.
Posted Apr 17, 2025 - 05:35 UTC
This incident affected: Nebraska 2, United States.