Texas 5 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 07:17 UTC

Identified

The site has a confirmed PDU down. Our on-site technician has already scheduled an electrician to fix the PDU. We will provide updates as necessary.
Posted Apr 14, 2025 - 07:44 UTC

Investigating

We are currently investigating this issue.
Posted Apr 10, 2025 - 09:18 UTC
This incident affected: Texas 5, United States.